What Android version is required for the TrainingPeaks Android app?

The TrainingPeaks mobile app for Android is currently compatible with Android OS version 5.7 and newer.  If your device can't be updated past version 5.7 then the TrainingPeaks apps won't work on your device.

Was this article helpful?
0 out of 0 found this helpful