What iOS versions is required for the TrainingPeaks mobile app?

The TrainingPeaks mobile app for iPhone and iPad is currently compatible with iOS version 10.0 and newer.  If your device can't be updated past iOS 8.7 then the TrainingPeaks apps won't work on your device.

Was this article helpful?
0 out of 0 found this helpful