What browsers are compatible with TrainingPeaks?

If you are experiencing issues with loading the TrainingPeaks site, please check that you are running the latest version of your browser.

The current latest browser versions that we recommend for using TrainingPeaks

Chrome 74 and newer

Safari 12.1 and newer (if you can't update to 12.1 then you may need to try updating your operating system)

Mozilla Firefox 66.0.05 and newer

Microsoft Edge (Note - Internet Explorer 11 is no longer supported)

Opera 55 and newer

Mobile browsers are not supported. If you are using a mobile phone or tablet then you will need to use the TrainingPeaks mobile app for Android or iOS.

Was this article helpful?
3 out of 10 found this helpful